【しばらく編集不可モードで運営します】 編集(管理者用) | 差分 | 新規作成 | 一覧 | RSS | FrontPage | 検索 | 更新履歴

プログラミングでの命名イディオム - ○○○は△△△と書くのが通例だ。

目次

○○○は△△△と書くのが通例だ。

類似(?) - こう読むのが普通だ

基本は…

アルゴリズムやデザインパターン、業務形態等の骨子となったものの用語はなるべくそのまま使った方が わかりやすい。

アクセサの命名方に関する意見

通常、たとえばデータを出し入れするメソッドを「SetFileData」「GetFileData?」のように命名する。 だが、大半の開発ツールではメソッドが名前順にリストアップされるために、このような対になるメソッドが 離れた場所に表示されてしまう。 そこで私はこのような時に「FileDataSet?」「FileDataGet?」というように命名している。 こうすると二つのメソッドがリストで並んで表示されるので把握しやすい。 でもこれは一般的な命名ルールに反するからね。。。。

単位

node
element
unit

関係

add/remove
join
register/cancel(deregister)

入出力処理

read/write
ストリーム。
get/set/put
ブロック。
send/receive
通信系。

生成処理

create
build
インスタンス生成+αな時...?
open
ファイルや接続などの場合。

初期化処理

initialize, init
setup
パラメータが多い場合...?

終了処理

destroy
リソースすべて破棄のような場合。
cleanup
tearoff
close
ファイルや接続などの場合。
dispose
リソース破棄。

接続関係

connect/disconnect
open/closeの方がいい場合もある。
connection
低レベルな接続の場合。
session
link
うーん・・・・

singleton的クラス(?)

○○manager
○○controler
○○observer
observer patternだけど。。。

参考文献

名付けの恣意性
http://wwwacty.phys.sci.osaka-u.ac.jp/~tokita/Papers/SouzouJissen.html


ううむ、命名に困るときは多々あるんだけど、どんなときに困ったのかが思いだせない・・・ (そしてまた同じケースで困るんだろうか)
 String drop_numbers(String str); //文字列から数字を取り除く
 String reverse(String str);      //文字列をひっくり返す
 
 String drop_numbers_and_reverse(String str) {
   return reverse(drop_numbers(str));
 }